Contents

Puffing and Straightening Hair ........................................ 47
Clumping Hairs Together or Spreading Them Out ............... 48
Interpolating Between Guide Hairs ................................. 49
Locking Selected Points on Strands ................................. 52
Progressive Styling by Freezing the Stack ....................... 54

Chapter 4

Dynamics, Collisions, and Forces .................................... 55
About Dynamics, Collisions, and Forces ...................... 56
Applying Dynamics to the Hair .................................. 57
Caching Files for Playback ........................................ 57
Adjusting the Hair’s Stiffness and Wiggle ..................... 58
Muting the Dynamics Operator for Styling ..................... 59
Creating Obstacles for Hair ...................................... 61
Defining Objects as Obstacles ................................... 62
Adding Natural Forces .............................................. 63

Chapter 5

Rendering Hair .......................................................... 65
About Rendering Hairy Things ..................................... 66
Shaders and Hair ....................................................... 67
Rendering Methods ................................................... 67
Connecting Shaders to Hair ....................................... 68
Using the Hair Renderer Shader .................................. 69
Optimizing the Render ............................................. 69
Caching the Lighting Information ............................... 69
Taking Advantage of Final Gathering ......................... 70
Coloring Your Hair .................................................... 71
Using Shader Presets ............................................... 75
Setting the Hair’s Transparency .................................. 76
Tips for Rendering Hair ............................................. 77

Index ................................................................. 81
Roadmap
Where to Find Information

The SOFTIMAGE|XSI package includes a comprehensive set of learning and reference materials. Use this Roadmap to find the information you need to get up and running quickly and effectively.

Start with the Setup & Licensing guide to install and license all components.

Refer to Limitations & Workarounds for this version, at softimage.com > support.

View the New Features Tour—a set of video clips giving overviews of the features and tools new to this version. If you installed the Tour with the XSI software, choose Help > New Features Tour from the main menu bar. Also browsable from the Documentation CD.

If you are new to XSI, work through the Tutorials to learn XSI in the context of basic productions. This is a full-color set of lessons showing you how to perform typical tasks step-by-step. You can install the scenes from the Media CD.

The Softimage Discussion Group
You can join the worldwide network of Softimage users exchanging ideas and techniques by e-mail. To find out more, e-mail majordomo@softimage.com. Leave the Subject line empty and type the word “help” in the body of your mail message. See Mailing Lists in the Softimage Customer Services section for instructions on joining the XSI mailing list.
Where to Find Information

**Hair**

**What's New in 2.0**
Summarizes all the new features since the last version of XSI.

**Online Help**
On-screen reference information on interface elements, commands, and parameters. To access:
- Click on the ? button in any property editor or data view that displays this symbol.
- Choose Help > Contents and Index from the main menu bar.

**Documentation CD**
Contains:
- Fully updated digital versions of XSI and mental ray® documentation in both PDF and HTML formats.
- New Features Tour
See the next page for how to use the Documentation CD.

**User Guides**
Conceptual and procedural information on how to use the XSI toolsets:
- Fundamentals
- Animation
- Modeling & Deformations
- Shaders, Lights & Cameras
- Rendering & Compositing
- Hair

**Global Index & Glossary**
An index to all user guides and Tutorials and a glossary of terms.

**Net View**
A portal to the world-wide XSI community right within XSI. Visit XSI Local for samples, tools, and documentation. Surf XSI Net for scripts and other resources. Net View is a Windows-only tool.

**The Command and Object Model Reference**
An HTML-based reference on all scripting commands, objects, methods and properties. To access: open the script editor and choose Help > Scripting Reference or click on ?.

**What’s New in 2.0**
Summarizes all the new features since the last version of XSI.

**The INTERFACE LAYOUT and the Quick Reference Card Common Shortcut Keys** will help you become familiar with the interface and keyboard shortcuts.
Using the Documentation CD

The Documentation CD contains the XSI and mental ray documentation in both PDF and HTML electronic formats. You can also browse the New Features Tour from this CD.

To access the online documentation

1. Insert the Documentation CD in your disk drive.
2. Open one of the following documents:
   - mainmenu.pdf (start page for PDF documents)
   - mainmenu.htm (start page for HTML documents)

For full-text searching and printing, we recommend PDF format. If you do not have Acrobat Reader installed on your system, you can install it from the Documentation CD.

For more information, follow the instructions in the Readme file on the CD.

Document Conventions

The following are ways that information is displayed in the XSI documentation.

Typography Conventions

<table>
<thead>
<tr>
<th>Type style</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Menu commands, dialog-box and property-editor options, and file and directory names.</td>
</tr>
<tr>
<td><em>Italics</em></td>
<td>Definitions and emphasis.</td>
</tr>
<tr>
<td><code>Courier</code></td>
<td>Text that you must type exactly as it appears. For example, if you are asked to type <code>mkdir style</code>, you would type these characters and the spacing between words exactly as they appear in this book.</td>
</tr>
<tr>
<td>&gt;</td>
<td>The arrow (&gt;) indicates menu commands (and subcommands) in the order that you choose them: <em>Menu name &gt; Command name</em>. For example, when you see <strong>File &gt; Open</strong>, it means to open the <strong>File</strong> menu and then choose the <strong>Open</strong> command.</td>
</tr>
</tbody>
</table>
Visual Identifiers

These icons help identify certain types of information:

- **Notes** are used for information that is an aside to the text. Notes are reminders or important information.

- **Tips** are useful tidbits of information, workarounds, and shortcuts that you might find helpful in a particular situation.

- The **3D icon** indicates information about differences in workflow or concepts between SOFTIMAGE|3D and XSI. You’ll find these very helpful when working with the two products.

- **Warnings** are used when you can lose or damage information, such as deleting data or not being able to easily undo an action. Warnings always appear **before** you are about to do such an action!

Keyboard and Mouse Conventions

XSI uses a three-button mouse for most operations. These are referred to as the **left**, **middle**, and **right** mouse buttons. In many cases, you will use the different buttons to perform different operations; always use the left mouse button unless otherwise stated.

The two-button mouse is not supported in XSI.

This table shows the terms relating to the mouse and keyboard.

<table>
<thead>
<tr>
<th>When this term is used...</th>
<th>...it means this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td>Quickly press and release the left mouse button. Always use the left mouse button unless otherwise stated.</td>
</tr>
<tr>
<td>Middle-click</td>
<td>Quickly press and release the middle mouse button of a three-button mouse.</td>
</tr>
<tr>
<td>Right-click</td>
<td>Quickly press and release the right mouse button.</td>
</tr>
<tr>
<td>Double-click</td>
<td>Quickly click the left mouse button twice.</td>
</tr>
<tr>
<td>Shift-click, Ctrl-click, Alt-click</td>
<td>Hold down the Shift, Ctrl, or Alt key as you click a mouse button.</td>
</tr>
<tr>
<td>Drag</td>
<td>Hold down the left mouse button as you move the mouse.</td>
</tr>
<tr>
<td>Alt+key, Ctrl+key, Shift+key</td>
<td>Hold down the first key as you press the second key. For example, “Press Alt+Enter” means to hold down the Alt key as you press the Enter key.</td>
</tr>
</tbody>
</table>
Softimage Customer Service

Technical support in North America for SOFTIMAGE|XSI is provided directly from Softimage Customer Service. Immediate assistance for any technical issue is available through hotline, and through electronic and web support services.

Softimage resellers working together with Softimage Customer Service provide support worldwide.

Licensing Support

You must contact your reseller to request a license for SOFTIMAGE|XSI. This can be done either directly or through the license request form provided at softimage.com/licensing

Training Support

If you’re interested in SOFTIMAGE|XSI training, you’ll find a complete overview of courses, education centers, and training programs at softimage.com/education

Hotline Support

If you’ve purchased a maintenance contract to receive support directly from your Softimage reseller, you’ll find assistance for contacting your reseller at softimage.com/Products/xsi/Add_Info/Buy/ In all other cases, contact Softimage Customer Service at the following numbers and during these hours:

<table>
<thead>
<tr>
<th>Region</th>
<th>Tel:</th>
<th>Hours</th>
</tr>
</thead>
<tbody>
<tr>
<td>World Wide</td>
<td>1 (514) 845-2199</td>
<td>9 AM to 7 PM (EST)</td>
</tr>
<tr>
<td></td>
<td>1 (514) 845-8252</td>
<td>2 PM to 12 AM (GMT)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1400 to 2400 (UTC)</td>
</tr>
<tr>
<td>North America</td>
<td>1 800 387 2559</td>
<td>9 AM to 7 PM (EST)</td>
</tr>
<tr>
<td></td>
<td>1 (514) 845-8252</td>
<td>2 PM to 12 AM (GMT)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1400 to 2400 (UTC)</td>
</tr>
<tr>
<td>UK and International</td>
<td>+ 44 1 753 650 670</td>
<td>9 AM to 6 PM (GMT)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>0900 to 1800 (UTC)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4 AM to 1 PM (EST)</td>
</tr>
</tbody>
</table>

Student/Teacher Program Support

If you’ve purchased SOFTIMAGE|XSI through the Student/Teacher program, installation support is offered by your reseller. Call Journey Education Marketing at 1-800-874-9001. Go to http://www.softimage.com/Education/XSI/BuyingSoftware/student_teacher.htm for more information.
Electronic Support

If you have an active maintenance contract and would like to reach us electronically, you will find a Support Request form at http://www.softimage.com/Support/XSI/TechnicalSupport/supportrequestform.asp

For general inquiries about Softimage support services, send an email to support@softimage.com

Web Support

The Support and Download sections of softimage.com provide quick access to a wide range of resources from the XSI teams and user community. Downloads—including Presets, Scripts, and Quick Fix Engineering (QFEs)—provide the latest solutions for XSI. Online user guides, tutorials, and knowledge-base articles ensure you get the most out of working with XSI. It’s like having a dedicated Softimage Customer Service engineer sitting at your desk!

Mailing Lists

If you have an e-mail account, you can join the worldwide network of XSI users exchanging ideas. To subscribe to the XSI discussion group, send an e-mail to majordomo@softimage.com with subscribe XSI as the body of your message. Use the message lists for information on related groups. Visit softimage.com/Archives/Help.htm for more information about our discussion groups and mail server.

The discussion groups are provided for technical exchanges between customers. Although customer service is not provided through these discussions, we do contribute.

Softimage Customer Service Addresses

North America

Softimage Customer Service
3510 Saint-Laurent Boulevard
Montreal, Quebec
H2X 2V2 Canada

UK and International

Softimage Customer Service Europe
Pinewood Studios
Pinewood Road
Iver Heath, Buckinghamshire
SL0 0NH United Kingdom
Comments?
If you have anything you’d like to say or ask about the XSI documentation, please do not hesitate to e-mail us at editors@softimage.com.
Chapter 1  Hair Simulations in XSI
Chapter 1 • Hair Simulations in XSI

Things Are Getting Hairy Around Here

Give me a head with hair—long beautiful hair. You can have it long, straight, curly, fuzzy, snaggy, shaggy, ratty, matty ... you get the idea. Yes, in XSI you can make all sorts of hairy and furry things—from Lady Godiva to hedgehogs and trolls, there are few limits to the hairy possibilities. Even aliens can have hair.

XSI Hair is a fully integrated hair generator that interacts with elements of the scene’s environment, such as lighting, other objects, and natural forces. As a result, you can create shadows for hair, create collisions using the actual objects, and apply dynamics and forces to make the hair move.

Hair comes with a set of styling tools that allow you to groom and style the hair, almost as easily as if it was on your head! You can control the styling hairs one at a time, or grab hundreds and style as you please.

To control the rendered look, you can use either a special shader designed for hair, or any other shader in XSI. And as with all things rendered in XSI, you can use the render region to preview accurate results.

What Makes Up Hair?

Hair is actually an assembly of different parts that work together: the hair generator, the hair object (geometry), the emitter object, the guide and render hairs, the dynamics engine, and the hair shader.

- The hair emitter is the object from which the hair is emitted. This is any object that you select and apply hair to.
- The hair generator is the operator that generates the hair strands.
- The hair object is the actual object whose geometry is displayed as guide hairs. These hairs are actually segmented curves that act like IK chains. Styling operators you apply define the look of the guide hairs.
- Render hairs are the filler hairs created from and interpolated between the guide hairs. These are the hairs that can be viewed and rendered.
Things Are Getting Hairy Around Here

- The **Hair Renderer shader** is a material shader that defines the rendered look of the render hairs, letting you set the color on the hair strands, add transparency, and optimize the rendering in different ways. You can also connect other standard XSI shaders to hair.

- If you apply dynamics to the hair, the **dynamics operator** is the engine that calculates the movement of the hair according to the velocity of the emitter object and any natural forces applied to the hair object.

**Finding Hair Elements in the Explorer**

In the explorer, you can see the relationship among all the parts that make up hair.

**Useful Tools for Hair**

**The Hair Property Editor**

When you create hair, the Hair property editor opens, allowing you to set viewing and render hair properties. See *Chapter 2: Creating and Viewing Hair* on page 19 for more information.

**To open the Hair property editor**

- Select the hair object and press Enter.

  or

- Click the Hair node’s icon in the explorer.

---

Hair • 15
Chapter 1  Hair Simulations in XSI

The Hair Panel

The Hair panel is your one-stop shopping center for styling tools. Styling is done on guide hairs, which are actually segmented curves that act like IK chains. The commands on the Hair panel let you perform a myriad of styling tasks, such as combing, clumping, cutting, and many others.

The Scale, Rotate, and Translate tools on the Transform panel also help you style the guide hairs.

For information on the hair panel and styling, see Chapter 3: Styling Hair on page 35.

Snapping Filter for Hair

To make it easier for guide hairs to snap to different objects when styling, use the Hair filter in the Snap menu in the main command area.

Using Mappable Parameters

Many of the parameters that define the look of the render hairs are mappable. Mappable parameters can have weight maps, texture maps, UV properties, and vertex color properties connected to them. The purpose of mapping is to modulate the effect that a parameter has using the values of the map. For example, you can change the colors on hair strands according to the color values on a texture map.

All mappable parameters are identified in the Hair property editor and Hair Renderer shader with a connection icon like this: •

You cannot connect weight maps to parameters in the Hair Renderer shader, only texture maps.

For an example of connecting a weight map, see Cutting the Render Hairs on page 31; for an example of connecting a texture map, see Coloring Your Hair on page 71.
Overview of Creating Hair

This visual overview shows how to get going with hair in XSI, followed by a list of chapters in which you can find more information for each step.

1. Apply hair to an object.
2. Style the guide hairs.
3. View the render hairs.
4. Apply dynamics and forces for hair movement.
5. Set up obstacles for collisions.
6. Adjust the shader or apply another one.
See these chapters for information

- For information on applying hair, see Chapter 2: Creating and Viewing Hair on page 19.
- For information on styling hair, see Chapter 3: Styling Hair on page 35.
- For information on viewing and adjusting render hairs, see Chapter 2: Creating and Viewing Hair on page 19.
- For information on adding dynamics and forces to hair, see Chapter 4: Dynamics, Collisions, and Forces on page 55.
- For information on setting up obstacles for hair, see Chapter 4: Dynamics, Collisions, and Forces on page 55.
- For information on shaders and rendering hair, see Chapter 5: Rendering Hair on page 65.
Chapter 2  Creating and Viewing Hair
Chapter 2 • Creating and Viewing Hair

Choosing the Hair Emitting Surface

The first step for creating hair is to set up the objects or components that will emit hair. Hair can be emitted from polygon mesh objects, polygons, polygon clusters, and NURBS surface and subsurface objects.

You cannot currently emit hair from point clusters, either on polygon or NURBS surface objects, or from geometry-approximated subdivided geometries.

· Polygon mesh objects. For polygon meshes, the resolution of the object determines how many guide hairs are created—one per vertex. This has an impact on the final look, but can be compensated for with the number of render hairs.

· Clusters of polygons or individual polygons (a cluster containing the polygons is automatically created when you add hair) allow you to emit hairs from only selected areas of the object.
Choosing the Hair Emitting Surface

The rendered hair starts abruptly at the edges of selected polygons, so you may want to design your model with a hairline created from many smaller polygons. You can also use a density map (see Removing Render Hairs (Density) on page 28) to attenuate the density of the hair growth near the hairline.

- **NURBS surface or subsurface objects.** The number of guide hairs is defined by the Geometry Approximation > Hardware Display of the object. For example, if you have a NURBS object with a 1 x 1 subdivision and a Hardware Display > UV Step of 3 x 3, then 16 guide hairs are generated, one at each vertex. To reduce the number of guide hairs, change the Hardware Display **before** you apply hair.

You can emit hairs from an object and then hide that object. This allows you to create a low-resolution hair emission object that closely resembles the high-resolution model that is seen.

**Changing the Topology of the Hair Emitter Object**

After you apply hair to the emitter object, you can change its topology, such as changing its subdivisions, or adding and deleting polygons or points.

Before you do this, however, you should freeze the hair’s operating stack (see page 54). This way, the hair looks for the guide hair at the closest vertex and bases the creation of new guide hairs on that one instead of using the default guide hair state.

However, if you scale an emitter object down to zero polygons, the hair object is lost, even if you add polygons to the “zero” object. You must reapply the hair.
Creating Hair

You can create, edit and render as many instances of hair as you like in a scene. When you create hair, a hair primitive object and its hair generator are created for each object or component to which you have applied hair.

You can apply hair to the same object, clusters, or polygons more than once. This lets you, for example, create short fluffy fur on an animal for its undercoat and long coarse hairs for its top coat. You can also create a lot of variation with the same hair object by styling areas of guide hairs differently and applying weight or texture maps to parameters (see Using Mappable Parameters on page 16).

To apply hair to an object

1. Make sure that the hair emitter object is appropriate for hair (see the previous section, Choosing the Hair Emitting Surface on page 20).

2. Select one or more hair emitting elements.

   If you branch-select an object, hair is applied only to the parent, not to the whole branch.

3. Choose Create > Hair > from Selection from the Hair panel.

As soon as you choose this command, guide hairs appear on the emitter, sticking out in the direction of the object’s normals. One guide hair is created for each vertex. Guide hairs are curves that you use to style the hair—all styling operations are described in Chapter 3: Styling Hair on page 35.

The Hair property editor also opens as soon as you create hair. This lets you view the render hairs and set their properties. See the next section, Viewing the Hairs on page 24, for more information.

The Hair Object

Applying hair creates a hair primitive object (appropriately called Hair) and its hair generator for each element to which you applied hair.

The hair object is a child of the hair emitter object, with its local transforms disabled. You can make hair a part of a character, especially within the structure of a model, and then transform that character as you like; for example, branch-select and transform the emitter object and the hair strands stay with it. The hair object’s centre, however, stays at the global origin which matters for deformations.
Deleting the Hair Object

When things get too hairy, you can delete the hair object by selecting either it or its hair generator operator and pressing Delete. This does not remove the hair emitter object.

To hide or display the hair object, toggle the Hair option on the Objects page in the Camera Visibility property editor (press Shift+s or click the eye icon in a viewport and choose Visibility Options).

Even though the hair is constrained to the emitter object, it can be offset using compensation, as with all other constrained elements in XSI. For more information, see Creating Offsets between Constrained and Constraining Objects in Chapter 9 in the Animation guide.
Viewing the Hairs

Hair is actually represented by two types of hairs: guide hairs (geometry) for styling, and render hairs for viewing and rendering. You can choose between displaying either the guide or render hairs in a viewport.

Render hairs are the “filler” hairs that are generated from and interpolated between the guide hairs. And as their name implies, render hairs are the hairs that are rendered. Color information is consistent with what you set in the shaders that are connected to the hair, and much tweaking of hair properties can be done without needing to use a render region.

Guide hairs are displayed when you select the hair object, regardless of the display type that is set.

For information on styling the guide hairs, see Chapter 3: Styling Hair on page 35; for information about render hairs, read the rest of this chapter.

To view guide or render hairs

- Select Guide Hairs as the Display Type in the Hair property editor to display only the guide hairs.

- Select Render Hairs as the Display Type to display only the render hairs. Then set the Render hairs % value to view only a certain percentage of the render hairs (the default is 10%). This value is a percentage of the Total Hairs value in the Render Settings section of the Hair property editor (see Setting the Number of Hairs Rendered on page 26). Increasing the percentage gives you a better sense of what the final results will be, but also slows down the interaction speed.
Whatever you set for the render hairs is reflected in the **Render Hairs** option and its percentage slider on the Hair panel, as shown on the left.

Select **Use Display Mode** to view the hairs using whatever display type is set in each viewport. Guide hairs appear in the Wireframe, Depth Cue, and Hidden Line Removal types, and render hairs appear in the Constant, Shaded, Textured, Textured Decal, and Realtime Shader types. This can speed up the interaction since you won’t have render hairs in every view.
Chapter 2 • Creating and Viewing Hair

Setting the Number of Hairs Rendered

There are a few different ways you can determine the number of hairs that are rendered, but the key for deciding this is the Total Hairs parameter in the Render Settings area of the Hair property editor. This value is the total number of render hairs shown for the hair object. The higher the value, the more hair, but with slower interaction and render time.

Also, the size of the hair emitter object makes a difference: 50,000 hairs over a small object is quite densely hairy, but the same amount over a large model looks much sparser.

The slider goes only to 50,000, but you can type in values much higher than this. The default value of 6500 hairs gives you enough hair for a decent preview while styling without slowing down the interaction too much. However, for final previewing and rendering, make sure to use a value much higher than this for a full head of hair.

Rendering a Percentage of Hairs

The Render Hairs % parameter for the Render Settings looks at the Total Hairs value and then uses a percentage of that to determine the number of hairs to draw when rendering, either in the render region or to file. Typically you would use 100% for the final render, but you can decrease this value to get a rough idea of the final result for quicker render tests.

The Render Hairs % parameter in the Display Settings does the same thing as the one in the Render Settings, but is only for viewing: this is not what is rendered in the region or to file.
Increasing the Number of Render Hairs

If you want to add more render hairs, you can use the Hair Multiplicity options in the Hair property editor. These use a multiplier value to increase the number of hairs at the root or tip of each hair strand. Keep in mind that using a large value can slow down interaction significantly because it’s adding a number of hairs to each render hair strand!

To increase the number of hairs

1. Set the Strand multiplier to a value above 0. For example, if you use a value of 5, five more render hairs are added to the root and/or tip of each render hair strand.

2. Set the Splay at root and/or Splay at tip value to be above 0 to use the Strand multiplier value:
   - **Splay at root** creates more hairs around the root area. Its value determines how far apart the copied strands are located in relation to the length of the hair: short hairs are placed closer to the original strand (splayed in less space) while long hair is splayed over more space around the original strand.
   - **Splay at tip** creates more hairs emanating from a root, creating the effect of sprouts—or hair plugs! As with Splay at root, its value is the amount of splaying in space as determined by the length of the hair strands.
Removing Render Hairs (Density)

If you want to remove render hairs, you can connect a weight or texture map to the Density Map parameter. You can determine the density of the render hairs in different areas on the hair emitter object. This parameter changes the total number of render hairs because it prevents hair from being displayed that would have otherwise been there.

When you connect a map, Density Map blocks out hair where the map has values lower than 1. For example, a value of 1 (such as pure white in a texture map) allows all the render hairs (as determined by the value for the Total Hairs parameter) to be displayed, while a value of 0 (such as pure black in a texture map) prevents any render hairs from being displayed. Any value in between is the probability of the render hair not being displayed.

For an example of how to connect a weight map to a parameter, see Cutting the Render Hairs on page 31.
Changing the Appearance of the Render Hairs

When render hairs are generated from the guide hairs, they take into account any parameters set in the Hair property editor. Many of these parameters let you control how the render hairs look, such as adding frizz or applying maps to parameters to temper their values. As well, dynamics applied to the guide hairs have a subsequent effect on the render hairs.

Many parameters in the Hair property editor can have maps connected to them, and are identified with a little connection icon beside them. For an example on how to connect a map to a parameter, see Cutting the Render Hairs on page 31.

Getting Started with Presets

On the Presets page in the Hair property editor, there are several presets that you can select to set the appearance of the render hairs, such as for an afro, curly hair, wavy hair, etc.

**To apply a preset**

- Select the hair and click one of the Preset buttons.

Setting the Render Hair Thickness

You can set the Thickness of the render hairs, which is the size (in pixels) at the root of the hair. This value is relative to the strand length so that at the same value, short hair strands are thinner than long hair strands.
Having thicker hair strands is faster for tweaking the hair style (such as with the default value of 3.6), then when you're ready for a more final preview or render, use a lower value such as 1.

**“Changing” the Hair Shape**

While you can’t change the actual shape of the render hairs (a tapered cone), you can make it appear as if the shape is changed by setting transparency values. For example, this can help you create bristles on brushes. For information on transparency, see Setting the Hair’s Transparency on page 76.

On the Transparency page in the Hair Renderer property editor:

1. Set the Tip Transparency to 0 (fully transparent).
2. Set the Root Transparency to 1 (fully opaque).
3. Set the Root/Tip Crossover Range to 0 so that there is a sharp contrast between the tip and root transparency levels.
4. Adjust the Root/tip Crossover Point value until it looks as if the hair is “clipped,” creating a flat end. It will still look like a clipped cone, but by lengthening the hair a bit, the results are quite close to a cylinder between the root and the crossover point.

**Setting the Render Hair Resolution**

You can determine the resolution of the render hairs by specifying the number of its segments and sides.

**Number of Hair Segments**

Each guide hair is always composed of 15 segments, regardless of the hair length. However, you can affect the hair’s resolution by setting the number of Hair Segments used to calculate the render hairs. The default is 10 segments.
over the length of each strand, but you may want to increase this to a value around 50 or more for long hair, or styles that have lots of curl or frizz. Of course, nothing is for free: higher values equal more processing time. Sorry.

Setting the Number of Sides (Cross-Section)
The number of sides (the cross-section) of a render hair determines how smooth it appears. For example, to make hair with three sides (the minimum), set the Cross-section points value to be 3. The higher the value, the rounder the hair strand.

This parameter is taken into account only when geometry is passed to the renderer; that is, when the Render Type is set to Geometry—it has no effect with Volume. See Rendering Methods on page 67 for more information.

Cutting the Render Hairs
Using the Cut Map parameter, you can determine the length of the render hairs in different areas on the hair emitter object based on a map connected to it. The length of the guide hairs is first taken into account, then the map is applied.

Cut Map makes the hair shorter where its connected map has values lower than 1. For example, a value of 1 (such as pure white in a texture map) makes all the render hairs the full length of the guide hairs, while a value of 0 (such as pure black in a texture map) cuts the render hairs at the root so that you won’t see them. Any value in between is a portion of the guide hair length starting at the root.

If you’re painting a weight map on a detailed model, always start out with the base map as 0 (black) and then add value to it. If you start the other way around, you won’t be able to “erase” the values for the vertices in places like the mouth and deep creases. And you don’t want hair in your mouth.
**Example: Connecting a Weight Map for Cut Maps**

Here's how to connect a weight map to the Cut Map parameter:

1. Paint the map data onto the surface of the hair emitter object and create a weight map as usual. For information in general on weight maps, see Weight Maps in Chapter 12 in the Fundamentals guide.

2. Select the hair emitter object and click the Transfer Map button on the Hair panel. This transfers the map from the emitter to the hair object and prompts you to pick the weight map.

3. In the explorer, pick the emitter object's weight map that you created. Under the hair object's Cluster folder, you'll see a new map that matches the one you transferred from the emitter object.

4. In the Hair property editor, click the Cut Map parameter's connection icon and choose Connect, and pick the map that you just transferred to the hair object.

   The connection icon shows that a map is connected. You can click on this icon to open the weight map's property editor.

   After you connect the map, you can go back and paint some more on the emitter object, and the connected map is updated.

   ![Weight map showing black areas at 0 and turquoise areas at 1.](image)

   **Unfortunate dog has fur cut according to weight map.** Fur that corresponds to 0 on the map is cut to the root, and fur that corresponds to values over 0 is cut according to its value, up to 1 which is full fur length.
Changing the Appearance of the Render Hairs

**Frizzing Out**

You can make hair appear frizzy by using the appropriately-named Frizz parameters. These parameters work by adding a rotation with noise to the hair.

*Frizz Frequency* is the frequency of the rotation noise pattern and is relative to the hair emitter object’s size. This means that the same value produces the same number of “bends” on small objects as on large objects.

*Frizz at root* and *Frizz at tip* add the noisy rotation to the strand using a value within the range of 0 to 180. This value is scaled by three different harmonic noise fields, whose frequency is set by the *Frizz Frequency* value. With *Frizz at root*, the rotation starts from the root, while *Frizz at tip* starts the rotation at the tip.

[Image of frizzy hair with annotations: Frizz at root and tip both set to 100 with Frequency set to 50. Frizz at root at 10 and Frizz at tip at 120 with Frequency set to 50.]

**Adding Kinks or Waves**

The Kink parameters also apply noise to the hair, but in this case it’s a displacement of each point along the hair strand. The effect you see is kinky or wavy hair.

*Kink Frequency* is the relative frequency of the Kink noise pattern and is relative to the strand length. This means that with the same value, short strands have as many kinks as long strands.

The Kink parameter applies the noise to displace the points on the hair. It controls the strength or amplitude of the kinks using the *Kink Frequency* value.
Chapter 2 • Creating and Viewing Hair

Render hairs with Kink frequency and Kink value both at 10.

Render hairs with Kink frequency at 15 and Kink value at 17.

Render hairs with Kink frequency at 40 and Kink value at 30.

Render hairs with Kink frequency at 40 and Kink value at 60.
Chapter 3  

Styling Hair
Chapter 3 • Styling Hair

Basics for Styling the Guide Hairs

When you’re styling, you always work with the guide hairs: these are the styling hairs that are similar to and behave like IK segmented chains. In fact, the most intuitive way to style hair is to grab a tip and position it the same way you would the end effector on an IK chain.

Guide hairs are geometrical objects, which means that you can perform many of the standard XSI operations on them as you can with any other geometry (such as transforming, deforming, etc.). Guide hairs are composed of 15 segments, regardless of their length. Even when you “cut” the guide hairs (page 41), the hairs are actually scaled down to keep the same number of segments.

The Styling Tools

You can do all hair styling using the operators on the Hair panel, as well as the standard Scale, Rotate, and Translate tools on the Transform panel; for example, use the Scale tool to change the hair length.

To open the Hair panel

- Press Ctrl+4. Press Ctrl+1 to switch back to the other toolbars.
- Click the scissors icon at the bottom of the toolbars.
- Choose View > Views > Hair Panel from the main menu bar.

About the Styling Operators

Each styling tool is an operator that gets added to the hair object’s stack, as displayed in the explorer. When you select and use a styling tool, it is combined with the previous results. As with other operators in XSI, you can mute them, delete and undo operations, as well as freeze the stack (see Progressive Styling by Freezing the Stack on page 54).

When you use a styling tool, its property editor is added as a page to the Hair property editor—you won’t see the editor automatically appear on its own as with many XSI operators. The parameters in these property editors let you mute the operator, as well as further refine some of the operations.

Switching between Styling and Dynamics

If you’ve applied dynamics on the hair object, you cannot style the hair unless you mute the dynamics operator, which you can do easily by clicking the Style button at the bottom of the Hair panel, as well as a few other ways.

See Muting the Dynamics Operator for Styling on page 59 for more information on styling when dynamics is applied.
Deforming the Guide Hairs

Because guide hairs are actual geometry, you can use all of the standard Deform operators on them (select all or just specific strands) to come up with some groovy ‘do’s! Lattices, deform by cluster center, randomize, and deform by volume often produce the most favorable results.

You can use the deformations only as modeling/styling tools because you cannot currently animate the deformations themselves when they’re applied to hair.
Chapter 3 • Styling Hair

Selecting Hair

Before you style, you must select the guide hairs. Using the buttons on the Select panel, you can select hair in different ways. The styling results can be very different depending on whether you’re selecting tips, whole strands, or just certain points on the strands.

With the hair object selected, use any of these options on the Select panel:

- **Strand**—Select the hair strands (all points on the strand) by dragging over any part of the strand. This tool simply selects all the points on the hair strand as a convenience—there is no such thing as a strand “component.”

- **Strand By Root**—Is your hair a tangled mess and you want to select a strand without trying to untangle? Select Strand By Root, drag near the surface of the emitter object, and the whole strand is selected.

- **Tip**—Select just the tips of the strands. Drag over any part of the hair strand, and only its tip is selected.

- **Point**—Select points on the hair strand as with any object. With this option, you can see the segments on the hair strand (always 15).

To move the point selection up and down the strand one segment at a time, press Alt+left or right arrow. This is handy, for example, to position the point on the strand before cutting it.

When you select points on the hair, the strand and point information is shown in the Selection text box. For example: `pnt [(2, 3), (2, 4)]` means that points 3 and 4 on strand 2 are selected.
Creating Clusters of Hair

You can create clusters of different points, tips, or strands of hair like any other geometry component in XSI. To do so, select the elements you want in the cluster and click the Cluster button in the Edit panel. For more information on clusters, see Clusters in Chapter 13 in the Fundamentals guide.

Once you have a cluster, you can use them as you would any other cluster, such as constraining objects to them using the Object to Cluster constraint (see Object to Cluster Constraints in Chapter 9 in the Animation guide).
Chapter 3 • Styling Hair

Changing the Hair Length

There are different ways in which you can change the length of the hair.

To change the hair length

1. Select the hair strands, tips, or points on the hair object (make sure you don’t have the hair object itself selected). The points on the guide hairs are always equidistant, so you really only need to select one point on a strand to scale the whole thing.

2. Select the appropriate Scale tool (X, Y, Z) on the Transform panel, and drag the mouse to the right to lengthen and to the left to shorten.

To attenuate the hair length

You can also scale the guide hairs proportionately to the size of corresponding polygon on the emitter object: smaller polygons produce shorter guide hairs. Attenuation is good for fur because you usually need the hairs to be shorter in the areas of high detail, and longer in areas of low detail. Choose the Attenuate command a few times in a row to initially set the length, then adjust by scaling the guide hairs to the exact length you want.

1. Select at least one point on each of the strands you want to attenuate, or select the hair object to attenuate all strands.

2. Choose Modify > Length > Attenuate on the Hair panel. Choose this command repeatedly to iteratively alter the hairs.
Changing the Hair Length

To reset hairs along the normals

- Select hair strands and choose Modify > Length > Pop Selected. This resets the hair, returning the hairs to their default state (sticking out in the direction of the emitter object's normals) at the default length.

- Select the hair object and choose Modify > Length > Pop Zero Hairs to lengthen hairs that have been scaled down to zero and can't be selected (useful if you've gotten a little overzealous with the cutting!). This also makes the hairs stick out in the direction of the emitter object's normals.

In the Hair Pop Operator property editor, you can set the Zero Threshold value to choose at what point (in Softimage units) that “zero hairs” will pop out. This makes it possible for hairs that are almost zero to be popped.

Cutting Hair

You can cut (shorten) the guide hairs similar to what you would do in real life: pick a point and snip! Although it appears that the guide hairs are cut, no segments are actually removed or harmed during this operation; instead, they are scaled to length you've specified and then refitted to that portion. This makes it possible to lengthen a hair cut that was too short, something we would have all liked to have done at some point in our lives!

To cut guide hairs

1. Select a point on the hair strand where you want to cut, or select the hair object itself.

   Press Alt+left or right arrow key to move up or down the strand to select a point before cutting.

2. Choose Modify > Cut. The hair is cut at the selected point, and a point remains selected relative to the length of the strand so that you can keep on cutting.

   If you selected the hair object, one hair segment is cut from each strands' end.
3. If the cut wasn’t exactly what you had in mind, you can change it. In the Hair Cut property editor, you can set the Offset parameter to add a relative offset to the cut, allowing you to change the hair point that was selected and cut. For example, an offset of -1 cuts at the point before the one you selected (resulting in shorter hair), and a offset of 1 cuts at the point after.

You can also alter the hair length by attaching a texture or weight map to the Cut Map parameter in the Hair property editor (see Cutting the Render Hairs on page 31). This determines the length of the render hairs based on the pattern of the map that’s connected. The guide hairs are not affected by this.

Removing Hair

There are two different ways to remove hair, such as for creating bald spots, shaved patterns in hair, or mowed patterns in grass. You can either:

- Scale the selected guide hair strands down to 0.

  or

- Connect texture or weight maps to the Density Map (see Setting the Number of Hairs Rendered on page 26) or Cut Map parameters. This is especially useful for quickly creating patterns of hair removal. Density Map determines the number of hairs based on the map that’s connected to it, and Cut Map determines the hair length.
Combing Hair

As in real life, combing hair in the virtual world is a basic requirement for grooming. You can comb the guide hairs in different directions according to the emitter object’s normals, the three axes, or away from the camera in a viewport. Combing orients the guide hairs in the way you specified and tries to follow the hair emitter object’s surface curvature as much as possible.

To comb hair

1. Select at least one point on each of the guide hairs, or select the hair object itself to comb all hairs.

2. Choose one of these commands from the Comb menu in the Hair panel:
   
   - **Along Normals**: Makes the hairs stand on end in the direction of the emitter object’s normals, as is the case with the initial groom state when you create hair. This command uses the Hair Puff operator (see page 47).
   
   - **Along Axes**: Combs in the positive or negative X, Y, and Z axes directions in global space.
   
   - **Away from Cameras**: These combing patterns are based on the four viewports (labelled A, B, C, D in their upper-left corners). They each comb away from the camera currently assigned to the viewport. The most common way to use this is to orbit the camera and then comb; for example, orbit the camera in the B viewport and choose Comb > Away from Camera View B.
3. To comb more accurately, the Comb property editor contains two parameters of use:
   - **Comb Amount** lets you specify the amount of combing you want, where 1 is fully combed and 0 is the previous state without any combing.
   - The X, Y, Z options let you select a vector that defines the combing direction.

**Tips for Combing**

- After combing, you may need to use the Puff > At Root command to lift the hairs away from the hair emitter’s surface (see **Puffing and Straightening Hair** on page 47).
- To “comb” a part between the hairs, use the Interp > Split command (see **Interpolating Between Guide Hairs** on page 49).
- Translating strands of hair on different axes also “combs” the hair in different directions (see **Styling with Rotation and Translation** on page 45).
Styling with Rotation and Translation

As with other geometry in XSI, guide hairs can be translated and rotated using the standard tools found in the Transform panel.

For rotating, you have additional options using the commands in the Rotate menu on the Hair panel. Note that points on the hair may not always rotate in a perfect arc because of the way the fixed-length segments on the guide hairs are connected.

To translate hairs

1. Select the hair strands, tips, or points on the hair object (don’t select the hair object itself).
2. Select the appropriate Translate tool (X, Y, Z) on the Transform panel and drag the mouse.

The selected elements move in the direction you drag. When you move the tips, the results are similar to moving the effector on a multi-segmented IK chain.

To rotate hairs

Use either of these tools:

- Select the hair strands, tips, or points, then select the appropriate Rotate tool (X, Y, Z) on the Transform panel and drag the mouse.

  
  
  or

- Select the hair tips or points, then choose a command from the Rotate menu on the Hair panel:

  - **Around Root** rotates strands, tips, or points around their roots perpendicular to the emitter object’s normal. Drag the mouse to the left or right: the farther you drag, the more the points are rotated.
- **Around Tip** rotates points around a vector from the root to the tip. This is useful for setting the orientation of a strand. Drag the mouse to the left or right: the farther you drag, the more the points are rotated.

- **Around Cursor** rotates tips or points around the initial mouse pointer position in the viewing plane. In a viewport, click at the point around which you want to rotate the hairs, and then drag the mouse to the left or right. The farther you drag, the more the points are rotated.

When you select one of these Rotate operators, you can have further control by setting the **Rotation Angle** value (in degrees) in the Hair Rotate property editor.
Puffing and Straightening Hair

There are times when you just need a little more volume in your hair, or you need to straighten it out. The two commands in the Puff menu on the Hair panel can help you with these styling problems.

To puff hair at the roots

- Select some hair strands or points and choose Puff > At Root on the Hair panel.

As you drag the mouse, the hair straightens (puffs) out starting at the root, moving it away from the emitter object’s surface. The further you drag, the more the points are straightened.

To straighten hairs

- Select some hair strands or points and choose Puff > Stand on End on the Hair panel.

As you drag the mouse, the hair straightens out, starting at the tip. The further you drag, the more the points are straightened.

For either of these Puff operators, you can change the amount of straightening that happens by setting the Puff Factor in the Hair Puff property editor. A value of 0 results in no change, and 1 results in completely straight hairs.
Chapter 3  •  Styling Hair

Clumping Hairs Together or Spreading Them Out

There are certain hair styles that require a good gel or mousse to make the hair stick together in clumps. You may also need hair to clump together for making eyelashes or animal whiskers. Likewise, you may need to do the reverse: to fan the hairs apart.

Using the Clump command on the Hair panel, you can do either operation, depending on which direction you drag the mouse. Clumping moves points on guide hairs either toward or away from their average center. For this reason, you’ll have the best results when points are fairly close together.

To clump or fan hair

1. Select some points on hair strands (such as the tips on several strands that you want to clump together).

2. Choose the Clump command on the Hair panel. Drag the mouse to the right to clump the points together, or to the left to fan the points apart. The farther you drag the mouse, the more the points are displaced.

3. You can also set the Clump Factor in the Hair Clump property editor to determine the way in which the points are moved. Positive values move the points toward their average center, and negative values move them away from their average center.

![Guide hairs with tips selected before clumping/fanning.](image1.png)

![Tips are clumped together toward an average center.](image2.png)

![Tips are fanned apart away from an average center.](image3.png)

You can also create the wet-hair look by using the Hair Multiplicity > Splay by Tips parameter in the Hair property editor—see page 27.
Interpolating Between Guide Hairs

There are hair styles that are easier to create when you can use groups of hairs. The commands in the Interp menu on the Hair panel let you decide the relationship between groups of guide hairs: you can split groups of them apart (such as for creating parts in the hair), merge them together, or have them all completely separate with no interpolation.

When you set the guide hair interpolation, the render hairs associated with each guide hair are also interpolated accordingly. For example, if you split one group of guide hairs from another, half the render hairs between the guides follow one guide and the other half follow the other guide.

To see the results of these commands, make sure that you have the render hairs displayed.

To split hairs apart

1. Select a group of guide hairs (or at least one point on each of them) that you want to split off from the rest, such as for creating a part.

2. Choose Interp > Split. This creates an interpolation group of these hairs.

You'll see that this group's render hairs do not interpolate with the others.
Chapter 3  •  Styling Hair

To merge hairs together

1. Select all the guide hairs (or at least one point on each of them) that you want to bring together.

   For example, you may want to do this after you’ve created a part with some guide hairs on the top of the head, but you want the hairs on the back of the head to be together.

2. Choose **Interp > Merge**. This activates the interpolation of render hairs between guide hairs that have been previously split or shattered.

   When guide hairs are merged, an asterisk is displayed next to the interpolation group ID, when the Group IDs are visible (see page 51).

   ![Guide hairs only at the front have been merged. There is interpolation in the front again, but a split remains down the middle and at the back.](image)

To keep all guide hairs separate

1. Select all the guide hairs (or at least one point on each of them) that you want to keep as islands unto themselves with no interpolation. For example, this is useful for creating porcupine quills or spiky gelled hair.

2. Choose **Interp > Shatter**. This separates each selected guide hair into its own interpolation group.

   You’ll see that each guide hairs’ render hairs do not interpolate with the others.

![Guide hairs only at the front have been merged. There is interpolation in the front again, but a split remains down the middle and at the back.](image)
To see the guide hair assignment

1. Press Shift+s or click the eye icon in a viewport and choose Visibility Options.

2. In the Camera Visibility property editor, select the Hair Interpolation Group IDs option on the Attribute page.

   This shows which guide hairs belong to which interpolation group. The group's ID is shown at the base of each hair with an asterisk beside the number stating that the hair has been merged.
Locking Selected Points on Strands

You can lock selected points of the hair strands to the emitter object’s surface, letting all the unselected ones roam free. For example, you can use this to create ponytails by fixing the points on the hair strands where the hair would be held together by a rubber band.

The locked points move with the emitter object, and you can move the locked points themselves, but the points stay locked down in relation to the strand when you apply dynamics or styling operators. The selected points are locked in space relative to the closest polygon on the hair emitter object.

To lock and unlock points on hair

1. Select some points on hair strands and choose Modify > Surf. Lock > Lock. By default, locked points are displayed with a little blue padlock icon.

2. Add dynamics to the hair or apply a styling operator. The locked points are not affected, and all other points on the hair strand are allowed to move freely.

For a pony tail, you may also want to lock down all points for hair that is directly on the head so that they’re not affected by dynamics.

3. Select the locked points and choose Modify > Surf. Lock > Unlock to unlock the points and have them be affected by dynamics and styling.

If you scale hair tips with locked points, the hair snaps back. Make sure to unlock any points before scaling, then relock the points, if necessary.
To hide or display the hair lock icons

1. Press Shift+s or click the eye icon in a viewport and choose Visibility Options.
2. In the Camera Visibility property editor, toggle the Locked Hair Points option on the Attribute page.
Chapter 3 • Styling Hair

**Progressive Styling by Freezing the Stack**

When you use a styling tool, its operator gets added to the hair object’s stack, as you can see in the explorer. You can freeze the hair object’s operator stack as you would any object in XSI (see *Freezing the Operator Stack* in Chapter 3 in the *Modeling & Deformations* guide for more information). Freezing collapses all the styling operators into the hair generator operator. You can also use the Immediate mode on hair, which doesn’t keep any operators in the stack. See *Immediate Mode* in Chapter 3 of the same guide.

Freezing the stack lets you style the hair progressively, taking advantage of the dynamics at each new hair state. For example, do some styling, add dynamics and move the hair around to enhance the styling, and then freeze the stack. The results, taking into account the dynamics and any styling operators that are present, are “baked” into a new hair state that becomes the current state. With this new state, you can continue building the style, and dynamics are applied relative to the new hair state.

*To freeze the hair’s stack*

- Select the hair object and click the Freeze button in the Edit panel of the main command area. All the styling operators are deleted, but the hair generator operator remains.

If dynamics are applied to the hair, its operator is not removed and remains at the top of the stack, above the hair generator operator.

![Hair stack with styling operators before freezing.](image1)

![Hair stack with styling operators gone after freezing.](image2)
Chapter 4  Dynamics, Collisions, and Forces
About Dynamics, Collisions, and Forces

By applying dynamics to hair, you can have it respond to the movement of the hair emitter object, as well as any obstacles set up for it. You can play back the dynamics live while you’re tweaking to get just the right motion, or write the simulation to cache files and then read them for faster playback.

You can also apply any or all of the natural forces available in XSI to create such scenes as fields of golden wheat, swaying gently in the breeze of a lazy afternoon in late summer ... or a fan blowing the hair of a beautiful blonde “model”!
Applying Dynamics to the Hair

When you apply dynamics to hair, you make it possible for the hair to move according to the velocity of the hair emitter object, like long hair whipping around as a character turns her head quickly. The dynamics calculations also take into account any natural forces applied to hair such as gravity or wind (see page 63) as well as any collisions of the hair with obstacles (see page 61).

To apply dynamics to hair

1. Select the hair.
2. Choose Create > Dynamics on the Hair panel.
   When you choose this command, a hair dynamics operator is added to the hair object’s stack (above the hair generator operator), and the Dynamics Operator property editor appears in which you can cache files for faster playback (see below).
3. On the timeline, select the Loop icon and click Play. By default, the dynamics are played back in live mode.
4. Move the hair emitter object around or animate its transformations, apply a force to it, or have obstacles collide with the hair.

Caching Files for Playback

You can cache dynamic simulation files for faster playback using the options in the Hair Dynamics Operator property editor. Caching the simulation to file means you can move to any frame and get an update, as well as play the simulation backward.

By default, the Cache Mode is set to Live (no caching) so that you can work with the time looped and have the hair update constantly based on any changes you make to the hair parameters.

To write to and read from cache files

1. Select Read & Write as the Cache Mode. When you change a hair parameter, the simulation is reset and the cache is cleaned, but nothing is recomputed until you change frames.
Chapter 4 • Dynamics, Collisions, and Forces

2. Enter a location and name for the cache file. By default, it writes to the Simulation folder of the current project (with Rel selected, meaning relative to the current project). If you want to use the actual folder path, enter it in its entirety and click Abs (and no, this button will not give you rippling “abs”!).

3. Play the simulation to cache the files.

4. Click Clear Cache to delete the current cache files in the folder; that is, it won’t clear cache files with names different from what is currently set for the Filename. The dynamics are not reset when you delete the cache.

5. Click Reset Dynamics to reset the hair to its state at the time that dynamics was applied.

The cache file is not automatically copied with the scene if you save it in a new project. Make sure to copy the cache files to the Simulation folder (or wherever you want them) in the new project so that you don’t lose valuable data!

To have the dynamics read from cache files

Select Read only if you want the dynamics to read data from the current cache file, but not write new cache files, even when you make a change to the hair.

• If you keep the cache files, make sure to check the storage folder you have defined for them and delete any unused files. These can build up and take up lots of space if you don’t occasionally do some housecleaning!

• To increase the speed of the playback, mute any viewport that you’re not using by middle-clicking its letter (A, B, C, or D). You can also hide the default grid in any viewport (press g.)

Adjusting the Hair’s Stiffness and Wiggle

In the Hair property editor, the Dynamics parameters on the Effects page affect hair when dynamics is applied. While these parameters are applied to the render hairs, the effect of these settings are also visible on the guide hairs.
Applying Dynamics to the Hair

- **Stiffness** is the tendency of the hair to hold its original shape and resist the dynamics that are affecting it, rather like hair spray! A value of 1 means that the hair will always keep its styled shape.

- **Wiggle** simulates the effect of a light breeze, randomly moving about the points of the guide hairs. Its **Amplitude** controls the strength or amount of the point displacement, and its **Speed** controls how quickly or slowly the displacement occurs, like seaweed slowly swaying with the waves or wheat stubble on a field quivering in the wind.

**Muting the Dynamics Operator for Styling**

Once you've applied dynamics on the hair object, you cannot do any hair styling using the commands on the Hair panel unless you mute the dynamics operator. This is because dynamics need to be calculated on a specific styling "state" that cannot change during playback.

If you style the hair with dynamics active, nothing will happen because no styling operator is added to the stack (and you'll see an error logged in the script editor).

**To mute the dynamics operator**

1. Do one of the following:
   - Click the **Style** button at the bottom of the Hair panel.
   - Select the **Mute** option in the Hair Dynamics Operator property editor.
Chapter 4  •  Dynamics, Collisions, and Forces

- Right-click on the Hair Dynamics Operator in the explorer and choose Mute.

2. Style the hair into a new state.

3. Unmute the dynamics operator.

Now when you play back the simulation, the dynamics operator uses this new state to update the dynamics.

When you reapply styling after dynamics, the hairs may have shifted a little. To get back to the “real” current hair state, click the Style button, click Reset Dynamics in the Dynamics Operator property editor, or move the hair emitter object.
Creating Obstacles for Hair

If you’re creating medium to long hair, you will most likely need to set up obstacles with which the hair will collide. For short hair, fur, or short grass, you may not need any obstacle objects, depending on what your hairy object is doing.

If you’re creating a human head, the shoulders and neck need to be selected as obstacles; or if you have an animal run through a field of wheat, it would be considered an obstacle.

Tips for Setting Up the Obstacle Objects

Here are some tips for setting up the objects that will be used as obstacles:

- You can use polygon or NURBS surface objects as obstacles, but you can’t use implicit objects. As well, the objects can be either stationary or animated.

- You may want to use polygons as obstacles to create more accurate collisions: a polygon’s points lie directly on its surface unlike those of a NURBS surface object.

- To prevent hairs from going into the head (or body, etc.) resulting from certain hair styles or dynamics, you may need to select the hair emitter object itself as an obstacle. You can also create an obstacle that is positioned slightly inside the hair emitter object and set that as an obstacle. This obstacle can be the same size or slightly smaller than the emitter object (make sure it’s not visible). If the obstacle is larger than the emitter, the hairs stand on end until they’re outside the obstacle.
Defining Objects as Obstacles

You can define any number of standard XSI geometric objects (polygon or NURBs surface) in your scene to act as obstacles that collide with hair, including the hair emitter object itself.

You can select objects as obstacles whether or not dynamics is already applied to the hair. If dynamics is not applied yet, obstacles are simply not evaluated until it is applied—they are only updated during hair styling operations (such as move points, puff, etc.).

To define objects as obstacles

1. Select the hair that you want to have collide with the obstacles.
2. From either the Hair panel or the Simulate toolbar, choose Modify > Environment > Set Obstacle.
3. Pick one or more objects in the scene that will act as obstacles for the hair. Right-click to end the picking session.


Adding Natural Forces

You can add further realism to a hair simulation by having their movement affected by these standard XSI forces: gravity, wind, fan, eddy, vortex, and attractor. Each hair object can have more than one natural force applied to it, and you can also apply the same force to any number of hair objects in a scene.

For more information on forces, see Chapter 8: Natural Forces in the Simulation guide.

To apply forces to hair

1. Make sure dynamics is set on the hair objects (see page 57).
2. Do one of the following:
   - Select the hair objects and choose Create > Forces > force name from the Hair panel (or the appropriate force from the Get > Forces menu in any other toolbar).
   - Create the force, then choose Modify > Environment > Apply Force and pick the hair objects to which you want to apply the force.
Chapter 5  Rendering Hair
### About Rendering Hairy Things

Rendering hair is similar to rendering any other object in XSI. You can use all standard lighting techniques (including final gathering and global illumination), set shadows, apply motion blur, and do field rendering (see page 77 for tips on using these with hair).

While you can use any type of XSI shader on hair, there is a special hair shader called the Hair Renderer shader that gives you the most control and options for making hair look the way you want. With it, you can control the tip and root colors, the transparency, and the way the illumination values are mixed, as well as render optimizations. See page 69 for more information.

The Hair renderer shader allows you to use either the volume or geometry rendering type. However, if you use a shader other than it, you can only use the geometry type. See page 67 for more information.

⚠️ You cannot currently echo hair to an MI file.
**Shaders and Hair**

To create a rendered image of hair for either the render region or rendering to file, you apply a shader to it, just as you would for any other object in a scene. The main shader that you use to render hair is the Hair Renderer shader, which is applied to the hair by default when you create hair. This is a surface shader that allows you to set the color, shadows, transparency, etc. of the hair.

You can use other XSI shaders on hair because it creates real geometry (for example, you can use the Phong shader). However, doing this does not give you as many options for accurate coloring, transparency, shadows, etc. as the Hair Renderer shader provides.

**Rendering Methods**

The Hair Renderer shader uses either the volume (default) or geometry rendering method. If you want to use any shader other than the Hair Renderer shader, you must use the geometry method.

*To select the rendering method*

1. With a shader attached to the hair object (see next page), open the Hair property editor and select either Volume or Geometry from the *Render Type* list.

   - With **Volume**, the hair’s bounding box is passed to the renderer, and volumic calculations are performed to determine whether a ray intersects a hair. This method is quite fast as compared to the geometry method. You can use this method only with the Hair Renderer shader.

   - With **Geometry**, the same shading algorithm is used as for any XSI surface shader. Hair is converted into geometric data (triangles) before being passed to the renderer. This method is fairly slow compared to volume.
Connecting Shaders to Hair

The Hair Renderer shader is a surface shader that you can connect to the Surface, Shadow, and Photon inputs of the Material node of the hair object.

You can also connect other shaders, such as the Phong shader attached to the Hair Renderer’s material input to replace the shader’s own illumination calculations. Or connect a different shader altogether to the hair object’s Material node.

**To reconnect the Hair Renderer shader**
1. Open the Render Tree view and choose Nodes > Hair > Hair Renderer.
2. Attach the shader’s output to all inputs on the hair object’s Material node.

**To connect other shaders**
1. Load the shaders and attach their outputs to either:
   - The appropriate Material node of the hair object.
   or
   - The Hair Renderer shader’s material input.

   If you do the latter to use another shader’s values for illumination or transparency, you must deselect the appropriate Enable option in the Hair Renderer shader’s property editor (see Coloring Your Hair on page 71 and Setting the Hair’s Transparency on page 76).
2. Select Geometry as the Render Type in the Hair property editor to see the results in the render region and final render (see the previous page for rendering types).

For general information about the render tree, see Chapter 4: The Render Tree in the Shaders, Lights, & Cameras guide.
Using the Hair Renderer Shader

As previously mentioned, the Hair Renderer shader gives you more control over accurate strand coloring, transparency, and shadows. As well, you can optimize the render and cache lighting information to speed up the render process.

For information on coloring, see Coloring Your Hair on page 71; for information on setting transparency, see Setting the Hair’s Transparency on page 76.

Many of the parameters for this shader are mappable (any one with a little connection icon [ ]), meaning that you can connect texture maps to them to create specific effects. For an example of this, see page 73.

To modify the parameters for the Hair Renderer shader, open its property editor from the explorer, the render tree, or choose Modify > Shader from the Render toolbar.

Optimizing the Render

On the Render Optimization page in the shader’s property editor, you can set a value for the Voxel grid size. This controls the number subdivisions (voxels) of the hair bounding box used when preprocessing the hair strands. When a ray enters a voxel, only the hairs that are inside that voxel are checked for intersections. This speeds up rendering, but the optimal value for this parameter depends on the specific hair object. For best results, do not use values lower than 8.

This option works only for the Volume render type.

Caching the Lighting Information

At the bottom of the Illumination page in the shader’s property editor, you can activate the Shading Caching option.

When this option is on (default), lighting information is calculated for all points on a hair the first time a ray hits it, and then lighting values are interpolated from the cached data as needed.

When this option is off, the exact lighting is calculated each time a ray hits a hair, which slows down the process.

You’ll probably want to keep this option on to speed up rendering. However, in some situations it may cause missing highlights (especially for long hair where the distance between vertices may be relatively large) or “swimming” artifacts. In these cases, turn this option off.

This option works only for the Volume render type.
Taking Advantage of Final Gathering

If you have final gathering set in your scene, you can also have it affect the hair. To do this, set the Radiance value on the Indirect Illumination page in the shader’s property editor.

This parameter controls the color and intensity (strength) of the final gathering effect over the object’s surface. Also, if you connect a texture map to this parameter, you can reveal a final gathering on a specific location on the object.
Coloring Your Hair

Trying to cover up those dark roots? Leaving just a touch of gray? You can do these coloring activities and more with the various illumination parameters in the Hair Renderer shader. While you can apply any XSI shader to the hair object to define color, the Hair Renderer shader allows you to specify different root and tip colors, as well as where the root/tip color starts and ends.

In addition, if you’re using the Hair Renderer shader, you can drag and drop color presets from the Net View for instant hair coloring magic! (see page 75)

To color the hair strands

1. Open the Hair Renderer property editor.
2. On the Illumination page, specify the color information for the hair strands using the parameters outlined here:

   - **Enables** the shader’s illumination values. To use another shader’s values, connect that shader (see page 68) and deselect this option.
   - **Tip Color A** and **B** define the hair strands’ tip and mid-strand diffuse colors, respectively.
   - **Tip Color Balance** sets the balance between them: a value of 0 is mostly Tip Color A, and 1 is mostly Tip Color B.
   - **Root Color** defines the hair strands’ diffuse root color.
   - **Root/Tip Crossover Point** is that point on the strand at which root and tip colors switch. A value of 0 is mostly tip color and 1 is mostly root color.
   - **Root/Tip Crossover Range** is the way in which the root and tip colors blend together. A value of 0 is sharp contrast and 1 is full blending.
   - **Ambient/Diffuse Mix** lets you set the relative contribution of these two illumination types. A value of 0 is mostly Ambient, and 1 is mostly Diffuse.
   - **Color variation** mixes in random colors of the same value (not saturation). The original color is converted to HSV, the saturation is set to 1, and a random hue is picked. Then this color is mixed with the original color. A value of 0 is no mixing, while 1 is 10% mixing (you can type in values up to 10 for 100% mix). At 100%, you will only see some chromatically random colored hairs.
   - **Specular** sets the color of highlights on the hair.

All of the parameters on this page are mappable, meaning that you can connect texture maps to them to create specific effects. For more an example of using a texture map for colors, see page 73.
To see examples of the effects of some of the parameters, see this page and the next.

For more information on each parameter, click the ? icon in the property editor to open the Online Help.

**Setting and Balancing Tip Colors**

![Tip Colors A and B used for the following images.](image)

**Tip Color Balance** at 0 shows mostly Tip Color A.

**Tip Color Balance** at 0.2 shows more of Tip Color B.

**Tip Color Balance** at 0.5 shows both Tip Color A and B equally.

**Balancing Tip and Root Colors**

![Root/Tip Crossover Point](image)

**Root/Tip Crossover Point** at 0.2 shows mostly the combined A and B tip colors.

**Root/Tip Crossover Point** at 0.5 shows tip colors and root color equally.

**Root/Tip Crossover Point** at 0.8 shows mostly the root color.
Blending Tip and Root Colors

Example: Connecting a Texture Map to Color Parameters

This is a simple example of how to change the hair colors using the colors from a simple striped image.

When mapping a texture to the hair, the color of the individual strands are derived from the texture color found at the root of the hair, so make sure your map is painted accordingly.

1. Select the hair emitter object and choose Get > Property > Texture Map > Projection type (such as Cylindrical, Spherical, XY for a plane, etc.) that is appropriate for the shape of the object.

2. In the Texture Map property editor, select a picture file.

3. Select the hair object and click the Transfer Map button on the Hair panel. This transfers the map from the emitter object to the hair, and prompts you to pick the map.
Chapter 5 • Rendering Hair

4. In the explorer, pick the emitter object’s texture map that you created (in the object geometry Clusters folder), as shown on the left. When you pick the map, you’ll see a new map that matches the one you transferred under the hair object’s Cluster folder.

5. Do one of the following:
   - In the Hair Renderer shader’s property editor, click the connection icon for one of the mappable parameters (such as the Tip Color A/B or Root Color) and choose Image. Pick the texture map you transferred, or any other image.
   - In the render tree, choose Nodes > Texture > Image to create an image node and attach it to the mappable parameter you want on the Hair Renderer shader (tip and root colors, as shown below). Make sure to select the correct projection type in the Image property editor.

You will now see the fur on the unfortunate dog rendered using the colors from the image you mapped.
**Using Shader Presets**

Better than a shade card from your hairdresser or private colorist, you can have drag 'n drop hair color! There are many presets to choose from for hair colors, just like having your own virtual salon.

**To apply the presets**

1. Apply the Hair Renderer shader to the hair with the Volume render type selected (see page 67 for rendering types).

2. Open Net View in a viewport and choose XSI Local > Library > Render > Hair. Shown here are only some of the beautiful colors awaiting you.

**HAIR (VOLUME)**

3. Drag the presets and plop them on the hair object's Material node in the render tree or directly on the hair object itself. Admire.

4. Apply a good conditioner because coloring can leave your hair dry and lifeless.
Setting the Hair’s Transparency

The Hair Renderer shader lets you set the transparency level of the tips and roots of hair strands, as well as where their levels meet and blend.

For a cool tip on how to alter the shape of a render hair using transparency, see “Changing the Hair Shape” on page 30.

To set the hair strands’ transparency

1. Open the Hair Renderer property editor and click the Transparency tab.

   All of the parameters on this page are mappable, meaning that you can connect texture maps to them to create specific effects. For an example of this, see page 73.

2. Set the Tip and Root Transparency levels to have the hair completely opaque at the tip/root (a value of 0) or completely transparent (a value of 1).

3. Set the Root/Tip Crossover Point to defines the point along the hair strands at which the transparency switches from the root to tip transparency value. A value of 0 is mostly tip and 1 is mostly root.

4. You can also control the blending between the root and tip transparency values by setting the Root/Tip Crossover Range. A value of 0 provides a sharp transition (no blending), and 1 is full blending.

5. Select the Use transparency from textures option if you want to use the alpha channel of any texture connected to the root and tip color parameters (see page 71) as the transparency value.
Tips for Rendering Hair

While rendering hair is similar to rendering anything else in XSI, there are a few things to keep in mind.

The Hair’s Bounding Volume

One of the most important things is about the hair’s bounding volume: having a camera inside the bounding volume renders as expected; however, if the eye ray hits a non-hair object before it hits hair, no hairs are rendered for that segment. This also has an effect with secondary rays: reflective and refractive rays do not work unless they hit the bounding volume before anything else.

Shadows

You can have hair cast shadows on other objects in the scene, and even the individual hairs cast shadows on each other. In addition, the transparency levels set for the hair are taken into consideration when shadows are calculated.

As with anything else in XSI, casting shadows with hair depends on the number and types of lights you’re using. Make sure you have shadows activated for the lights you want to use.

You can have the hair cast shadows with light sources inside the hair’s bounding volume; however, if the eye ray hits a non-hair object before it hits hair, no hairs are displayed or shadows created for that segment.

For more information on shadows in general, see Creating Shadows in Chapter 10 of the Shaders, Lights & Cameras guide.

Motion Blur

When you use motion blur on hair, deformation blur is always done when you use the volume rendering method. When you use the geometry rendering method, however, you need to activate the Deformation blur option in the motion blur property or the Render Options property editor to get the best results. For faster results, turn this option off, as it can be quite time-consuming.

You can have motion blur on hair whether or not it has dynamics applied to it; however, without dynamics (live mode), the results are unpredictable. With dynamics on hair, make sure to select either Read & Write or Read only as the Cache Mode in the Dynamics Operator property editor (see page 57).

For more information on motion blur, see Creating Motion Blur in Chapter 13 of the Shaders, Lights & Cameras guide.
Field Rendering

You can use field rendering with hair as you would any other object in XSI. If you have dynamics applied to hair, make sure to select either Read & Write or Read only as the Cache Mode in the Dynamics Operator property editor (see page 57).

For more information on field rendering, see Field Rendering in Chapter 3 of the Rendering & Compositing guide.

Optimizing the Rendered Look

Here are some tips to consider when rendering hair:

- For precise results, make sure to do the final render with a high value for the hair segments (50 or more). The default value of 10 is useful for quick interaction while you're styling the hair but doesn't give high-resolution results. See Setting the Render Hair Resolution on page 30 for more information.
- Make sure you're rendering with shadows on (use higher umbra settings to scale them back a bit).
- Use lots of hair strands (Total Hairs value—see page 26) with a transparency value of about 0.2. This also decreases shadowing because it allows light to pass through the volume.
- Ambient/Diffuse Mix should be set with Ambient being predominant (around 0.2), and the Diffuse contribution at a minimum. Most of the shading comes from shadowing/specular.
- The specular value (not its exponent) should be very high for dark hair and very low for light hair.

Tips for Rendering White Hair

White hair or fur can be fairly difficult to achieve, so here are some things to consider:

- White hair is not white: it's chromatic gray. There are lots of tints of "off white" in white, but if you have the color turned to pure white (1), you won't have much variation.
- You don't want to fill up the whole color spectrum range with the base color: you need to allow a little room for the specular color (which is additive). The white should be brighter than anything else in the frame, so make sure your subject and background don't compete.
- White hair is self illuminating, in that light bounces all over the place inside. There is very little diffuse range, which means that the hair's shading is mostly the base color—anything else comes from shadows. You can set the Ambient/Diffuse Mix parameter so that it's mostly Ambient (about 85%) to diminish the effect of the diffuse shading. In other words,
the shaded hair (pre-shadow) is just the base hair color with no dark-to-light variation. The rest of the shading comes from the shadows and specular value. It’s not ambient in the traditional sense because the setting doesn’t affect the shadow density.

- Use lots of hair strands (Total Hairs value—see page 26) that are very transparent. This allows lots of light to pass through the volume, giving a nice fluffy appearance, if you’re trying to create fluffy fur.

- Try applying multiple instances of hair to the same object, each with different density settings (if it’s fur): one long and loose (low stiffness, higher frizz), and one short, dense, and stiff.
Chapter 5 • Rendering Hair
Index

A
attenuating hair length 40

B
bounding
volume for hair 77
brushing hair See styling hair

C
caching hair files for playback 57
clumping hair 48
clusters
on hair 39
collisions
with obstacles (hair) 61
colors
hair 71
combing hair 43
cross-section
of hairs 31
cutting hair
cut map 31
cut operator 41

D
deformations
on hair 37
density
of hair 28
dynamic behavior on hair 57
locking and unlocking points 52
versus styling 59
dynamics operator for hair
muting 59

E
emitter objects for hair 20
eplorer
hair elements in 15

F
field rendering
hair 78
files
cache for hair playback 57
final gathering
and hair 70
freezing
hair 54
frizzy hair 33
fur See hair

G
grooming hair See styling hair
guide hairs
See also styling hair
about
displaying 24

H
hair
See also guide hairs
See also Hair Renderer shader
See also render hairs
about 14
bounding volume 77
collisions with obstacles 61
color 71
creating 22
deforming 37
deleting 23
density of 28
displaying 24
dynamics 57
dynamics versus styling 36
default object 20
genergy and volume
rendering 67
kinks 33
main property editor 15
mappable parameters 16
motion blur 77
natural forces on 63
number of 26
number of sides 31
operator stack 36, 54
optimizing the render 78
overview 17
playing simulation 57
primitive object 22
removing strands 42
rendering 66
resolution 30
selecting components 38
setting length 40
styling See styling hair
thickness 29
transparency 76
white hair 78
hair emitter 20
creating hair on 22
hair interpolation group IDs 51
Hair panel 36
hair primitive object (Hair) 22
Hair Renderer shader
about 69
caching light information 69
colors 71
final gathering 70
genergy and volume
rendering 67
in render tree 68
transparency 76
voxel grid size (subdivisions) 69

I
interpolation
between guide hairs 49

K
kinky hair 33

L
lights
caching information for hair
shader 69
locking
points on hair 52
Index

**M**
mappable parameters
  - hair 16
merging
  - hair interpolation 50
motion blur
  - for hair 77
muting
  - dynamics operator for hair 59

**N**
natural forces
  - on hair 63

**O**
obstacles
  - and hair 61
operator stack
  - hair 36, 54

**P**
parameters
  - mappable for hair 16
playing
  - hair simulations 57
points
  - selecting on hair objects 38
popping hair 41
presets
  - render hairs 29
  - puffing hair 47

**R**
render hairs
  - about 27
  - adding 27
  - cutting 31
  - density 28
  - displaying 24
  - frizz 33
  - kinks and waves 33
  - number of 26
  - number of sides (cross-section) 31
  - percentage displayed 24
  - percentage rendered 26
presets 29
segments 30
splaying 27
stiffness 58
thickness 29
wiggle 58
render tree
  - hair shaders in 68
rendering
  - hair 66
  - number of hairs 26
  - rotations
    - hair points 45
shattering interpolation 49
splitting interpolation 50
spreading 48
straightening 47
translating points 45
unlocking points 52
versus dynamics 36

**T**
texture maps
  - for hair 16
  - on hair colors 73
tips of hair, selecting 38
translations
  - hair points 45
transparency
  - for hair 76

**U**
unlocking
  - points on hair 52

**V**
viewing
  - hair
voxel grid size
  - in Hair Renderer shader 69

**W**
wavy hair 33
weight maps
  - for hair 16
white hair 78
wiggling hair 58